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Chapter 1: Welcome to Blender 5.1 

What You Will Learn in Chapter 1 

• Installing Blender 5.1 on Windows, macOS, and Linux — with platform-specific tips 

• A complete tour of all eight interface areas and what each one does 

• What changed from Blender 4.x to 5.x, and what's specifically new in 5.1 

• Navigating 3D space: orbit, pan, zoom, and all essential viewport shortcuts 

• Configuring Preferences the way a professional artist would — before doing anything 

else 

• The Extensions platform: 900+ free add-ons installable with one click 

• Saving your startup file so every new project begins exactly as you want it 

• Understanding Blender's data model: Objects, Data blocks, and why it matters 

• Practical Exercise: a complete eight-step first Blender session from scratch 

 

Blender is one of the most powerful pieces of software ever written — and it is completely free. In the 

hands of a single artist it can produce work that rivals the output of entire studio pipelines. Films have 

been made with it, video games shipped using assets built in it, and architectural visualisations 

presented to clients who had no idea they were looking at an open-source render. But Blender's 

reputation for a steep learning curve is well earned, and the single biggest cause of that curve is not 

the complexity of 3D itself — it is starting without a clear map of the terrain. 

This chapter is that map. By the end of it you will have Blender 5.1 installed, configured exactly the 

way a professional artist would configure it, and you will have completed a full practical exercise 

inside the software. We move quickly and stay practical — every section ends with something you 

can do, not just something you can read. 

 

1.1  What Is Blender — and Why Version 5.1? 

Blender is a free, open-source 3D creation suite that covers the entire creative pipeline under one 

application: polygonal modelling, digital sculpting, UV unwrapping, texturing, rigging, character 
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animation, physics simulations, visual effects, compositing, video editing, and Python scripting. It runs 

on Windows, macOS, and Linux, and is developed by the Blender Foundation — a non-profit based 

in Amsterdam — alongside thousands of open-source contributors worldwide. 

Blender 5.0, released in November 2025, was a landmark update that introduced full ACES colour 

pipeline support, the completely rewritten EEVEE Next render engine, Geometry Nodes volumes and 

SDF (signed distance field) nodes, and major improvements to colour management and HDR 

rendering. Blender 5.1, released on 17 March 2026 with the 'Singularity' splash screen, is the 

polished, production-hardened follow-up — the version to learn on in 2026. 

 

Figure 1.1 — What's new in Blender 5.1: six key areas of improvement with full details 

The headline features of Blender 5.1 that appear throughout this book are the new Raycast shader 

node (available in both Cycles and EEVEE), dramatic animation playback performance 

improvements, rendering speed gains of up to 20% on CPU and 10% on GPU, the new Smooth 

(Gaussian) F-Curve modifier, upgraded Compositor nodes, and the Extensions platform now hosting 

over 900 free add-ons. 

 

TIP  Why Learn on 5.1 Specifically? 
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Blender 5.1 is the current stable release as of mid-2026. Every screenshot, shortcut, and 

menu path in this book maps directly to what you see on screen — no version mismatch. If 

you open a tutorial written for Blender 2.8 or 3.x, you will encounter interface differences that 

slow you down. Starting on 5.1 means everything clicks immediately. 

 

1.2  Installing Blender 5.1 

Installation is straightforward but there are platform-specific choices that will affect your daily 

workflow. Always download from the official source — blender.org/download — to ensure you have 

the verified, up-to-date release. 

Windows 

Download the .msi installer (recommended) or a portable .zip. The installer registers .blend file 

associations so double-clicking a .blend file opens Blender directly. The portable .zip is useful for 

running from a USB drive or on machines without administrator rights. 

• Run the installer accepting the default path. Ensure 'Register file associations' is checked. 

• On first launch, right-click the shortcut and 'Run as administrator' once — this allows Blender to 

write preference files correctly. 

• GPU backend: go to Edit > Preferences > System > Cycles Render Devices. Select OptiX for 

NVIDIA RTX or GTX 1000-series (driver 470+). Use CUDA as a fallback if OptiX causes errors. 

 

NOTE  CUDA vs OptiX 

OptiX is faster than CUDA on supported hardware but requires driver version 470 or newer 

and a GTX 1000-series or RTX card. If your GPU appears in Cycles Render Devices but 

renders produce errors, switch from OptiX to CUDA in Preferences > System. CUDA is slightly 

slower but more stable on older driver versions. 
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macOS 

Download the .dmg file, open it, and drag Blender.app to your Applications folder. On first launch, 

macOS Gatekeeper may block the app — if so, go to System Settings > Privacy & Security and click 

'Open Anyway'. 

• Blender on Apple Silicon (M1 through M4) runs as a native ARM application. Performance is 

exceptional, particularly on the GPU side using the Metal backend. 

• Metal is selected automatically. Verify it is active under Edit > Preferences > System > Cycles 

Render Devices — a green tick should appear next to your GPU. 

TIP  macOS Without a Numpad or 3-Button Mouse 

In Edit > Preferences > Input, enable 'Emulate 3 Button Mouse' (Alt+Click = Middle Mouse 

Button) and 'Emulate Numpad' (number row 1–0 = numpad views). This is essential for 

MacBook users and covered in detail in Section 1.5. 

 

Linux 

Blender distributes a portable .tar.xz archive for Linux — no root access required. Extract it, navigate 

to the folder, and run the 'blender' executable. Works on any distribution. 

• NVIDIA GPU: ensure the proprietary NVIDIA driver is installed (version 525.89 or higher for 

CUDA/OptiX support). 

• AMD GPU: the ROCm compute stack is required. Installation steps vary by distribution; consult 

the ROCm documentation for your distro. 

• Intel Arc GPU: oneAPI backend is stable in Blender 5.1. Install the latest Intel Arc driver from 

intel.com/arc. 

• Flatpak and Snap packages are community-maintained and sometimes lag behind the official 

release. For production work, always use the direct download from blender.org. 

 

1.3  A Tour of the Blender 5.1 Interface 

When you first open Blender 5.1 the Singularity splash screen appears. Click anywhere outside it to 

dismiss it. You are left with the default scene: a grey cube, a camera, and a point light. The 
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surrounding interface can look overwhelming at first, but it is built on a small number of consistent 

ideas that — once understood — make the entire application feel logical and predictable. 

 

Figure 1.2 — The Blender 5.1 interface with all eight main areas labelled and described 

The interface divides into eight distinct areas. Each is described below. Learning these names matters 

because every tutorial, manual page, and forum answer uses them — knowing 'the Outliner' from 'the 

Properties Panel' is the vocabulary of Blender communication. 

 ①① Topbar and Workspace Tabs 

The very top strip holds the application menus (File, Edit, Render, Window, Help) on the left, and the 

Workspace tabs running across the centre. The active workspace is highlighted. On the right are the 

Scene and View Layer selectors — used in complex multi-scene productions. Workspace tabs are 

explored in Section 1.4. ②② Header Toolbar 
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Immediately below the Topbar sits the header for the currently active editor. In the default Layout 

workspace this is the 3D Viewport header. It contains: mode selection (Object Mode, Edit Mode, 

Sculpt Mode, etc.), transform orientation and pivot point dropdowns, and the four shading mode 

buttons (Wireframe, Solid, Material Preview, Rendered) on the right. ③③ Tool Shelf  (T key) 

The narrow vertical strip on the left of the 3D Viewport is the Tool Shelf — context-sensitive tools for 

the current mode. In Object Mode: select, move, rotate, scale tools. In Edit Mode: more specific mesh 

tools appear. Press T to toggle it. Most experienced users prefer keyboard shortcuts, but the shelf is 

invaluable when learning which tools exist. ④④ 3D Viewport 

The large central area is the 3D Viewport — your working window into the scene. It shows a 

perspective projection by default, with a grid floor, world origin, and navigation gizmo. You can have 

multiple viewports open simultaneously by dragging the corner of any editor area. The 3D Viewport 

is where the vast majority of your time is spent. ⑤⑤ Navigation Gizmo 

The XYZ axis indicator in the top-right of the 3D Viewport is the Navigation Gizmo. Click the X, Y, or 

Z axis labels to align the view to that axis. The sphere in the centre toggles between Perspective and 

Orthographic projection. This gizmo is your visual compass — always readable regardless of how 

disoriented the view becomes. ⑥⑥ Timeline 

The horizontal strip at the bottom is the Timeline. It shows the current frame (orange playhead), the 

total frame range, and playback controls. For still-image work you can largely ignore it; for animation 

it becomes one of your most-used areas. Click and drag anywhere in the ruler to scrub the playhead. ⑦⑦ Outliner 

The top-right panel is the Outliner — a hierarchical tree of every object, collection, material, and data 

block in the scene. You can select, hide, rename, and organise objects here. Collections (the folder-

like containers) are the primary organisation tool. Chapter 2 covers the Outliner in depth. ⑧⑧ Properties Panel 
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Below the Outliner is the Properties Panel — the deepest area in Blender. A column of icons on its 

left edge switches between tabs covering Render, Output, View Layer, Scene, World, Object, 

Modifiers, Particles, Physics, Constraints, Object Data, Materials, and more. The active tab changes 

based on what is selected and what you are doing. You will use this panel in every chapter of this 

book. 

 

PRO  Customising the Layout 

Blender's interface is entirely customisable. Drag the corner of any editor area to split it into 

two panels. Drag toward a border to merge two areas. Right-click any border for a quick 

split/merge option. Change any area's editor type via the icon in the top-left of that area. Save 

your custom layout as a new Workspace tab. 

 

1.4  Workspace Tabs — The Right Layout for Every Task 

The tabs across the top — Layout, Modeling, Sculpting, UV Editing, Texture Paint, Shading, 

Animation, Rendering, Compositing, Scripting — are Workspace Tabs. Each is a pre-configured 

arrangement of editors optimised for a specific task. Switching workspaces does not affect your scene 

data — it only changes which editors are visible and how they are arranged. 

Think of workspaces as different desks in a studio. The Layout desk has a large viewport with a 

timeline. The Shading desk shows the Shader Editor node graph alongside the 3D viewport 

simultaneously. The Animation desk arranges the Dope Sheet and Graph Editor below the viewport. 

The Compositing desk opens the Compositor node graph. 

Add a new workspace: click the + button at the right end of the tab row. Delete a workspace: hover 

over a tab and press Ctrl+W, or right-click the tab. Rename: double-click the tab label. 

 

1.5  Navigating 3D Space — The Most Important Skill 

3D navigation is the first practical skill to master in Blender. Until it is second nature you will fight the 

software constantly; once it is automatic you will forget you are doing it. The goal of this section is for 
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you to navigate the 3D viewport instinctively by the time you have finished it. This is not achieved by 

reading — it is achieved by doing the motions repeatedly while reading. 

 

Figure 1.3 — Complete viewport navigation reference: mouse controls, numpad presets, and shading modes 

The Three Core Navigation Actions 

• Orbit — hold Middle Mouse Button (MMB) and drag. The view rotates around a pivot point at 

the scene centre. This is the most fundamental navigation move — you will perform it thousands 

of times per session. Build the muscle memory now. 

• Pan — hold Shift + MMB and drag. The view slides laterally without changing its rotation. Used 

to recentre the view on your work area. 

• Zoom — scroll the mouse wheel up/down. For smooth, precise zoom hold Ctrl + MMB and drag 

vertically. 

 

Numpad View Presets 
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The numpad gives instant access to standard orthographic views — professional artists use these 

constantly to check proportions and make precise edits. If you do not have a physical numpad, enable 

Emulate Numpad in Preferences > Input (Section 1.6). 

Shortcut Action 

Numpad 1 Front view (looking along -Y axis) 

Numpad 3 Right side view (looking along -X axis) 

Numpad 7 Top view (looking down -Z axis) 

Ctrl + Numpad 1 Back view 

Ctrl + Numpad 3 Left side view 

Numpad 5 Toggle Orthographic / Perspective projection 

Numpad 0 Camera view — exactly what the render will show 

Numpad . (dot) Frame selected — zoom viewport to fit selection 

Home Frame all — zoom to fit all visible objects 

~ (tilde) View pie menu — fast access to all views and modes 

 

Viewport Shading Modes 

The four shading buttons in the viewport header control how your scene looks while you work. Each 

serves a different purpose: 

• Wireframe — shows only edges — no fills, no lighting. Useful for topology inspection and 

working inside dense geometry. Alt+Z toggles between Wireframe and your previous mode. 

• Solid — the default working mode. Matcap-lit shading — no actual materials or scene lights, 

but fast and consistent for modelling. A good matcap makes it easy to read object volume and 

surface. 

• Material Preview — applies your actual scene materials and lights the scene with a built-in 

HDRI. The best representation of your final look without the cost of a full render. Essential during 

texturing and shading. 
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• Rendered — activates the full render engine (EEVEE or Cycles) directly in the viewport. The 

most accurate preview of your final output. Blender 5.1's performance improvements make this 

noticeably more responsive than previous versions. 

 

1.6  Configuring Preferences — Set Up Like a Professional 

Before doing any serious work, invest ten minutes configuring Preferences. These settings are saved 

globally and apply to every file. Open via Edit > Preferences (or Ctrl+, on some systems). The 

Preferences window has tabs on the left — the most important for new users are Input and System. 

 

Figure 1.4 — The Blender 5.1 Preferences window with the most critical settings highlighted and annotated 

Input Tab — Three Essential Settings 

• Emulate 3 Button Mouse — if you do not have a 3-button mouse, enable this. It maps Alt+Left-

Click to Middle Mouse Button, giving you full navigation on any mouse or trackpad. 

• Emulate Numpad — if you have no dedicated numpad (compact keyboards, laptops), enable 

this. It maps number keys 1–0 to the numpad view shortcuts. Note: this prevents those keys 

from entering numbers in text fields, but for 3D work the trade-off is always worthwhile. 
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• Zoom to Mouse Position — enable this immediately. It makes the viewport zoom toward 

wherever your cursor is positioned, rather than toward the screen centre. Once you use this, 

you will never go back. 

 

System Tab — GPU Configuration 

Under the System tab, scroll to 'Cycles Render Devices'. Select your GPU here: OptiX or CUDA for 

NVIDIA, HIP for AMD, Metal for Apple Silicon, oneAPI for Intel Arc. If nothing is listed, your GPU is 

not supported by Cycles — you will still render using CPU or EEVEE, both of which are fully capable. 

 

Viewport Tab — Matcap and Clipping 

In the Viewport tab, choose a matcap for Solid shading mode. The 'clay' or 'studio' matcaps are 

popular for modelling — they make it easy to read object volume without distracting colours. Also 

check the Clipping Start distance under View: if objects disappear when you zoom in very close, 

reducing the Near clip distance from the default to 0.001 m resolves this immediately. 

 

Saving Your Preferences 

Click the hamburger menu  ☰  in the bottom-left of the Preferences window and choose 'Save 

Preferences'. Or enable 'Auto-Save Preferences' in the same menu. Your settings are stored at: 

%APPDATA%\Blender Foundation\Blender\5.1\config (Windows) or ~/Library/Application 

Support/Blender/5.1/ (macOS). Back up this folder regularly if you have a heavily customised 

setup. 

 

1.7  The Extensions Platform — 900+ Free Add-Ons 

Blender 5.1's Extensions platform is a curated, community-reviewed marketplace of tools that extend 

Blender's capabilities. Over 900 free add-ons and themes are available, all installable with a single 

click from inside Blender. Access it via Edit > Preferences > Add-ons > Get Extensions at the top right 

of the Add-ons tab. 

Three Add-Ons to Enable Right Now 
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These three ship pre-installed with Blender — they just need to be enabled. They are used by virtually 

every experienced Blender artist and will appear throughout this book: 

• Node Wrangler — adds dozens of powerful shortcuts to the Shader Editor and Compositor 

node graphs — the single most-used convenience add-on in all of Blender. Enable it under 

Add-ons > search 'Node Wrangler' > tick the checkbox. No download required. 

• LoopTools — adds mesh editing tools including Relax, Space, Circle, Bridge, and Flatten to 

the right-click context menu in Edit Mode. Essential for professional polygon modelling. Enable 

the same way. 

• Extra Objects — extends the Shift+A Add menu with dozens of additional primitive meshes — 

gears, mathematical surfaces, honeycomb patterns, rocks, and more. Useful for exploration, 

prototyping, and testing shaders. 

 

NOTE  Add-On Version Compatibility 

Not all add-ons available online are updated for Blender 5.1. Before installing any third-party 

add-on from outside the official Extensions platform, verify the developer's page lists Blender 

5.x compatibility. Installing an incompatible add-on will not break Blender, but the add-on itself 

will produce errors or fail to appear in menus. 

 

1.8  Saving Your Startup File 

The startup file is the scene Blender loads every time you create a new file (Ctrl+N > General). By 

default it contains the cube, camera, and point light. Once you have configured Preferences and 

enabled your add-ons, save this state as your personal starting point. 

Set up the scene exactly as you want every new project to begin — for example: delete the default 

cube, set units to Metric in Scene Properties, position the camera, enable overlay options — then go 

to File > Defaults > Save Startup File and confirm. 

PRO  A Clean Startup File 

Many professional artists save a startup file with: the default cube deleted, units set to Metric, 

Node Wrangler and LoopTools enabled, and their preferred workspace layout. This cuts 30–
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60 seconds of setup from every new project — small per session, but significant across 

months of daily use. 

 

1.9  Understanding Blender's Data Model 

Two minutes spent understanding how Blender organises its data will save you hours of confusion 

later. This is the conceptual foundation that Chapter 2 builds on. 

In Blender there is a critical distinction between Objects and their Data. An Object is a container with 

a position, rotation, and scale in the scene. The Data is what the object contains — a mesh (the 

shape), a camera lens specification, a light type, a curve path. These are separate things stored 

separately. 

The key consequence: multiple Objects can share the same Mesh Data. Duplicate an object with 

Alt+D (a linked duplicate) and both objects reference the same shape in memory. Edit the mesh and 

both objects update. This is used heavily in game assets, tiled environments, and crowd simulations. 

Chapter 2 covers this in full depth. 

 

 

1.10  Practical Exercise: Your First Complete Session 

Now it is time to put everything in this chapter into practice. This eight-step exercise takes 

approximately 20–30 minutes. Do not skip it — the muscle memory built here carries directly into 

every chapter that follows. Open a new Blender file before starting: File > New > General. 
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Figure 1.5 — The eight steps of your first complete Blender session, with what to achieve at each stage 

Step 1: Launch and Dismiss the Splash Screen 

Open Blender 5.1. The Singularity splash screen appears. Click anywhere outside it to dismiss and 

enter the default scene. You will see three objects in the Outliner: Camera, Light, and Cube. These 

are your starting materials. 

Step 2: Navigate for Two Solid Minutes 

Before touching anything else, spend two full minutes on navigation only. Hold MMB + drag to orbit. 

Scroll to zoom. Shift+MMB to pan. Press Numpad 1 (front), Numpad 3 (right), Numpad 7 (top), 

Numpad 5 (toggle ortho/persp), Numpad 0 (camera view). 

TIP  Why Two Minutes? 

Navigation practice feels slow, but the investment is immediate and permanent. Professionals 

orbit and pan without thinking — the same way a driver changes gears without thinking. Those 

two minutes of conscious practice accelerate the rest of the book. 

Step 3: Select, Move and Rotate the Cube 
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Left-click the cube to select it (outline appears). Press G to grab, then X to lock to the X axis. Move 

your mouse, then Enter to confirm. Now try: G > X > 2 > Enter to move exactly 2 metres. Then 

R > Z > 45 > Enter to rotate 45°. 

Step 4: Add a UV Sphere 

Press Shift+A > Mesh > UV Sphere. A sphere appears at the 3D cursor position. Press G > Z 

> 2.5 > Enter to lift it 2.5 m above the floor. You now have two mesh objects in the scene. 

Step 5: Add a Ground Plane 

Press Shift+A > Mesh > Plane. Press S > 8 > Enter to scale it to 16 m × 16 m. Press N to 

check its Location Z = 0 in the N-Panel. This will serve as the ground in your render. 

Step 6: Apply a Material 

Select the cube. In the Properties Panel, click the Material Properties tab (the sphere icon). Click + 

New to create a material. Click the Base Color swatch and choose a mid-tone grey or any test colour. 

Set Roughness to 0.4 for a semi-glossy result. Switch to Material Preview (Z > Material Preview) to 

see the material in the viewport. 

Step 7: Check Camera View and Composition 

Press Numpad 0 to enter Camera View. You will see exactly what the render camera captures. If the 

composition is poor, press Numpad 0 again to exit, select the camera, and reposition it with G and 

R. Return to Numpad 0 to check again. Repeat until satisfied. 

Step 8: Render and Save 

Press F12 to render. A new window opens and EEVEE renders the scene. It should complete in 

under 10 seconds. Save the render: Image > Save As > 'chapter01_render.png'. Save the .blend file: 

Ctrl+S > 'chapter01_first_scene.blend'. 

 

TIP  Switching to Cycles 

EEVEE renders in seconds but Cycles is more photorealistic. To try Cycles: Properties > 

Render Properties > change Render Engine to Cycles > Device to GPU Compute > then 

press F12. It takes longer but the lighting quality is visibly higher. Use EEVEE for fast iteration 

and Cycles for final output. 
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Chapter 1 Summary 
Before moving to Chapter 2, confirm you can do all of the following without referring back to this 

chapter: 

• Install Blender 5.1 and configure the GPU render backend in Preferences > System. 

• Name all eight interface areas and describe what each one does. 

• Orbit, pan, and zoom the 3D viewport using the mouse. 

• Jump to front, top, and right orthographic views using the numpad (or emulated numpad). 

• Enable Emulate 3 Button Mouse and Zoom to Mouse Position in Preferences > Input. 

• Enable Node Wrangler and LoopTools from the Add-ons tab in Preferences. 

• Add an object with Shift+A, move it with G, rotate with R, scale with S. 

• Apply a basic material and render the scene with F12. 

• Save the .blend file with Ctrl+S and the render image from the render window. 

 

Master Shortcut Reference  
 

Shortcut Action 

MMB + Drag Orbit the 3D viewport 

Shift + MMB Pan the 3D viewport 

Scroll / Ctrl+MMB Zoom in and out 

Numpad 1 / 3 / 7 Front / Right / Top orthographic view 

Numpad 5 Toggle Orthographic / Perspective 

Numpad 0 Camera view (what the render sees) 

Numpad . (dot) Frame selected object 

Home Frame all visible objects 

~ (tilde) View pie menu 

Z Shading pie menu (Wireframe / Solid / Material / Rendered) 

Alt+Z Toggle X-Ray (see through mesh) 
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Shortcut Action 

T Toggle Tool Shelf 

N Toggle N-Panel (Item / Tool / View tabs) 

Shift+A Add object menu 

G Grab (move) — follow with X/Y/Z for axis lock 

R Rotate — follow with X/Y/Z for axis lock 

S Scale — follow with X/Y/Z for axis lock 

[key] then [number] Type exact value during any transform 

Enter / Left-click Confirm a transform 

Esc / Right-click Cancel a transform 

F12 Render image 

Ctrl+S Save file 

Ctrl+N New file 

Ctrl+Z Undo 

Ctrl+Shift+Z Redo 
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Chapter 2: 3D Fundamentals & Object Mode 
Essentials 

What You Will Learn in Chapter 2 

• The Blender data model: Objects, Mesh Data blocks, and linked duplicates 

• Transforms in full depth: G, R, S with axis constraints and exact numeric input 

• The N-Panel for precision: typing exact coordinates without touching a menu 

• Snapping modes: vertex, edge, face, grid, increment — and when to use each 

• Pivot points: the oft-misunderstood key to correct rotations and scales 

• Proportional Editing: organic mesh deformation via adjustable falloff radius 

• Collections and the Outliner: organising complex scenes professionally 

• Parenting objects: building hierarchies that move, rotate, and scale together 

• Object Constraints: Copy Location, Track To, Child Of, Limit Location, and more 

• Empties: the invisible structural workhorses of the Blender scene 

• Importing and Exporting: .blend, FBX, glTF 2.0, USD, OBJ, Alembic, STL 

• Practical Exercise: build and fully organise a multi-object room scene 

 

If Chapter 1 was about getting comfortable inside Blender's interface, Chapter 2 is where you learn 

to think in 3D. The skills covered here are the invisible foundation beneath every model you will ever 

build, every scene you will ever light, and every animation you will ever create. They are not 

glamorous — nobody posts a tutorial about the N-Panel — but the artists who master them are the 

ones who work quickly, avoid technical debt, and never end up with a scene so disorganised it 

becomes impossible to manage. 

We move systematically through Object Mode, which is the layer of Blender where you arrange, 

organise, and relate objects to one another. By the end of this chapter you will be able to build and 

manage scenes of real complexity — the kind that will support everything that follows in Chapters 3 

through 10. 

 


